Setting up the project


#1

I’ve tried to set up Thrive in VS12. However, I’ll be honest - I have no experience with using CMake, so keep that in mind if the solution to my problem happens to be extremely simple.

Namely, I’ve been using the CMake GUI application(version 3.4.1, the latest), however, I’m getting an error that “add_sources” is an unknown command. Would there be some kind soul out there to help me out with my plight?


#2

After trying and having failed at this for hours, I can surely say that it cannot by done using the normal setup scripts. You need to set it up by hand and download all of the dependancies.


#3

Got it. I guess I’ll try to set it up manually then.


#4

I’m not sure how much this’ll help, but add_sources is defined by us, in this file:


and called within each sub-folder of the project to add source files to the list to later be compiled/linked.

I’ve tried a couple of builds using cmake-gui, but can’t get the same error. Using ‘Codeblocks - MinGW Makefiles’, and ‘specify toolchain file for cross-compiling’ as options, and the default ‘C:/MinGW/cmake/toolchain.cmake’ toolchain works just fine without any other fiddling. Attempting the same with Visual Studio 10 (I don’t have 12 installed) returns an error about not finding ogre, nothing about add_sources. That may be related, as the FindOgre.cmake used is the default on in the CMake directory, not the one we provide in the projects cmake_modules folder, so for whatever reason that folder might not be being detected.

Sorry I don’t know how to fix that, but it may get you a little further. Note that I looked into building with visual studio when I first set up cmake, and found it to be far from simple, eventually giving up and settling for codeblocks (or netbeans).


#5

Thank you for your suggestions, I’ll try adding the add_source function and use Code::Blocks once I’m back at my computer.